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BE F OR E Y O U BE GIN … 
 
Use this guide during class to follow the topics as presented. The instructor may also provide 
additional materials to support the training outlined in this guide. After class, use this guide as a 
reference document for completing tasks within the PeopleSoft system. 
 
 

INT E NDE D AU DI E NCE 
 
This  guide  is  intended  for  personnel  who  are  responsible  for creating  reports  for  the  
PeopleSoft  system.    BI Publisher training assumes the trainee has attended a Basic and Advanced 
Query class and/or has basic query writing skills. 
 
 

HO W TH I S GU I DE IS OR G AN I ZE D 
 
This guide is organized into chapters that contain the topics your instructor will cover in class. Some 
chapters may have corresponding practices that follow the instructor‘s presentation and individual 
exercises for you to complete on your own. 
 
 

SY M B O L S A ND CO NVE NT I O N S 
 
The following conventions are used in this guide to help you distinguish between various types of 
information: 
 

SYMBOLS AND CONVENTIONS 

SYMBOL HOW IT IS USED 
bold text Command and toolbar buttons that you click. 

Menus, text and radio buttons that you select. Check boxes 
you turn on or off. 

Bold italic 
text (red) 

Text you type. 

<bold text> Function keys on your keyboard that you press. 
Italics text Identifies a Page name. 

Identifies a Field name. 
Hyperlink 
(blue) 

Indicates a link to another page. 

 Procedural information. 

 Warnings and cautions that require careful attention. 
Appears in 

       PeopleSoft information – definitions, helpful hints. Appears in 
the page margin. 
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SYMBOLS AND CONVENTIONS 

SYMBOL HOW IT IS USED 
 
 
 
 

Note – Noteworthy comments or important additional information— 
generally about the item immediately preceding the note. Appears 
in the main body of the document. 

 
 
 

Noteworthy comments or important additional information— 
generally used to call out specific client-related information about a 
series of steps or the topic being discussed. Appears in the page 
margin. 

 

 
 
 
 
 

You are 
encouraged to ask 
your instructor 
questions 
throughout the 
course. 

 
 
 
 

 

 

CH A P T E R S T R U C T U R E 
 
Most chapters are structured the same way and generally consist of the following: 
 

• Objectives are found at the beginning of the chapter and describe the material to be 
presented. 

• Topics explain the various concepts. Some topics contain practices and exercises. 
• Procedures are step-by-step instructions for completing a procedure that the instructor and 

class participants walk-through together. 
• Exercises  are  scenarios  for  you  to  work  through  on  your  own during class time. 

 
 

CO UR S E CO NT E NT 
 
The guide includes five chapters and four appendices: 
 
Chapter 1, “Introduction to BI Publisher”, explains the course objectives. Provides a brief review of BI 
Publisher. 
Chapter 2, “Install Oracle BI Publisher Desktop”, shows the steps in installing the BI Publisher for 
Word Add-In. 
Chapter 3, “Create or Modify and Existing Query”, explains the method to create or modify queries. 
Chapter 4, “Create and Register a Data Source”, shows how to register the query and create sample 
data or the schema. 
Chapter 5, “Create an RTF Template”, reviews the creation of an RTF template in Microsoft Word. 
Chapter 6, “Define a New Report”, explains linking the RTF template to the data source within 
PeopleSoft. 
Chapter 7, “Run and View the XML Publisher Report”,  shows how to run a BI Publisher report in 
PeopleSoft. 
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CO U R S E O B J E C T I V E S 
 
The purpose of this course is to provide the skills needed to effectively use BI Publisher. This course 
covers how to: 
 

• Define Data Sources 
• Create and Update RTF Template 
• Upload Report Definitions 
• Run and Review BI Publisher Reports 
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CHAPTER 1:  Introduction to BI Publisher 
 
Oracle Business Intelligence Publisher (BI Publisher, formerly XML Publisher) is an enterprise reporting 
solution that streamlines report and form generation. A primary feature of Oracle's BI Publisher 
product is the separation of the data extraction process from the report layout. BI Publisher enables 
you to design and create report layout templates with the more common desktop applications of 
Microsoft Word and Adobe Acrobat, and renders XML data based on those templates. With a single 
template, it can generate reports in many formats (PDF, RTF, Excel, HTML, and so on) in many 
languages. This approach to reporting can dramatically reduce report maintenance, enabling power 
business users to adjust report templates without involvement of IT resources. 
 
The following diagram illustrates the concept of BI Publisher. 
 

 
 
Select features of Oracle's BI Publisher product have been integrated into and enhanced for use with 
PeopleTools. Within PeopleSoft applications, this is referred to as XML Publisher (XMLP). 
 
There are four phases to creating BI Publisher Reports: 
 

1. Create and Register Data Source 
2. Create Report Template 
3. Define BI Publisher Report 
4. Run and View BI Publisher Report 

 
This guide will review each step. 
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CHA PT ER 2 –Install Oracle XML Publisher Desktop 

The XML Publisher Desktop/Template Builder is shipped with PeopleTools.  You can also download the 
software from the PeopleSoft XML Publisher page. 

1. From the left navigation bar in PeopleSoft Applications, select Reporting Tools> XML 
Publisher> Setup > Design Helper to download the Template Builder.  

 

2. Download the Template Builder by clicking the Plug-in link. You can save the download 
anywhere (for example, in c:\temp). 

 

3. After the download is complete, install XML Publisher Desktop. Open File Explorer and navigate 
to the download directory (for example, c:\temp). The following example shows the expanded 
files under c:\temp\xmlp_desktop. Double-click setup.exe to start the installation process. A 
set of installation wizard pages guide you through the installation process. 
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4. Select English, and then click Next. 

 

5. Ensure that no previous version of XML Publisher Desktop is installed. Click Next.  
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6. The XML Publisher Desktop requires the installation of Java Runtime Environment (JRE) version 
1.4 (or later versions). Enter the location for Java Runtime Environment and click Next.  

 

7. Deselect Open the Word Template Builder Tutorial file and click Next. Enter the name of the 
folder where you will install XML Publisher Desktop and click Next.  
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8. Click Install for the installation to start. 

 

9. When the installation is complete, click Finish.  
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10. After XML Publisher Desktop is installed, open Microsoft Word. Notice a menu item named 
Template Builder in the menu bar and a new toolbar.  (NOTE:  The template builder may also 
be in ‘Add-In’. 
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CHA PT ER 3 – Create or Modify an Existing Query 

BI Publisher uses Query and Connected Query as data sources for creating reports.  As users usually 
have queries already created, these can be used in BI Publisher. 

Practice :  Modifying an Query- Step-by-step example 

Initially you modify an existing query, PERSONAL_DATA_PAY, and apply criteria on DEPTID to reduce 
the volume of data. To modify the query, perform the following steps: 

1. Log in to your PeopleSoft Application. Then, from the left menu, select Reporting Tools > Query 
> Query Manager. Enter PERSONAL_DATA_PAY in the ‘begins with’ field. The query 
PERSONAL_DATA_PAY will return. 

 

2. To modify the query, click the Edit link under the Edit column. All the fields in the query are 
displayed. 
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3. Because the filter will be on DeptID, click the filter icon on DeptID.  

 

4. On the Edit Criteria Properties page, select in list from the Condition Type drop-down list.  
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5. Click the search icon for List Members in the Edit List box.  

 

6. Enter 0103 and click Add Value.  
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7. Similarly, add the departments 0104 and 0106. When all the departments are entered for the 
criteria, click OK. 

 

8. On the Edit Criteria Properties page, click OK. 
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9. Click the Run tab and run the report. Make sure only three departments (ADMIN, ADMISSION, 
and ALL DEPTS) are returned. The query should return rows. 
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Notes 
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CHA PT ER 4 – Create and Register a Data Source 

Understanding Data Generation 

In BI Publisher, the data extraction is separate for the data presentation. Sample data can be used to 
design your RTF template and map your PDF templates. Data schema was used in previous releases for 
the bursting feature and is still available for backwards compatibility and bursting. If PeopleSoft queries 
are used for data extraction, the system will generate the schema; for all other data sources, you must 
create the data schema using tools outside of the PeopleSoft system. 

XML Publisher can register PS/Query, Connected Query, and XML files as a data source, but you can 
generate XML data using any means including PS/Query, SQR, Application Engine, PeopleCode, File 
Layout, and so forth.  

For RTF template-based reports, design your data source XML structure using groupings that resemble 
the groupings needed for the output report. This improves runtime performance by preventing 
unnecessary grouping by the formatting engine. 

Understanding Data Source Registration  
A data source registers the schema and sample data design files. The extracted application fields from 
the data source files are placed into the template files to create the final report. 

The data source can be PS Query, Connected Query, or XML files.  

Benefits of data source registration include the ability to:  

• Reuse previously registered data sources with multiple report definitions.  
• Take advantage of built-in bursting features.  

Registering Data Sources 
1. Log in to your PeopleSoft Application. Then, in the left navigation bar, expand Reporting Tools > 

XML Publisher > Data Source.  
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2. Because you will use a PS query, click Add a New Value. Select PS Query as the Data Source 
type and click the Look Up Query search icon for Data Source ID. 

 

3. Enter P in the begins with field and click the Lookup button. 

 

4. Scroll down and click PERSONAL_DATA_PAY. 
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5. Click the Add button on the Data Source page. 

 

6. On the Data Source page, in the Data Source Properties section, enter the Description as 
Departmental Annual Salary. Click Generate under the Generate File column for Sample Data 
File and Schema File. 

 Page 25 
 



Creating PeopleSoft Reports using XML Publisher 
 

 

7. After the data source is generated, an XML file for PERSONAL_DATA_PAY is created. Click the 
Save button. 
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8. Click the PERSONAL_DATA_PAY.XML file. The browser appears and displays the XML data in 
the file. Save the XML file in the C:\temp folder.  
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CHA PT ER 5 – CREATE REPORT TEMPLATES 

Using RTF Templates 
RTF templates support most XSL functionality and can be designed with robust processing and 
formatting code.  

Creating RTF Templates 

You use a Microsoft Word plug-in to build an RTF template. You use a preexisting RTF template file 
named Personal_Data_Pay.rtf. 

• Load XML Data in a Word Template 
• Create a Pie Chart and a Bar Chart 
• Create a Table 

Load XML Data in a Word Template 

You open a base template and load the XML data. To load the XML data, perform the following steps:  

1. Open the file named Personal_Data_Pay.rtf in Microsoft Word 

 

2. Click Data and select Load XML Data. 
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3. In the Please select XML data dialog box, select the PERSONAL_DATA_PAY.xml file and click 
Open. 

 

4. When the "Data loaded successfully" message appears, click OK. 

 

  

Create a Pie Chart and a Bar Chart 

If you do not want to create a pie chart or a bar chart, skip this section. 

To create a pie chart and a bar chart, perform the following steps: 

1. From the first cell in the table, delete the text <insert a pie chart here>. From the menu, select 
Insert > Chart. 
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2. In the Chart window, select Row and enter the details as shown below.  

 

3. Click OK. Resize the pie chart to fit within the width of the cell. 
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4. Similarly insert a bar chart. Delete the text <insert a vertical bar chart here>. Select 
Insert>Chart from the menu. In the Chart window, select Row and enter the details as shown. 

 

5. Click OK. Resize the bar chart. 
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6. Save the template and preview in PDF format. Click Preview and select PDF from the drop-
down list. 

 

Create a Table 

You create a tabular report for which you have already loaded the data. To create a table, perform the 
following steps: 

1. Move the cursor below the table for the charts, add some blank lines, and insert a new table. 
Click Insert and select Table/Form.. from the drop-down list. 
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2. The Insert Table/Form window appears. Select Row from the Data Source list on the left. 
 

 

3. Drag Row from the left to the Template column and select Drop all Nodes. 
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4. Delete the following fields by selecting the field and clicking the delete button: 

• @rownumber  
• Position Nbr  
• Acct Cd  
• Monthly Rt  
• Hourly Rt  

As a result, you should have four fields. 

 

5. Provide grouping details. Select Row in the template column and, from the properties window, 
select DEPTID from the drop-down list for the Grouping property.  
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6. Click OK. You are returned to Word. Resize the table to match the image below by dragging the 
sizing handles for the columns. 

 

7. Use Word features and select the G DEPTID field and cut and paste above the table. 

 

8. Select the inner table and the control character E (as shown).  

 

9. Cut and paste the selected area a few lines below the outer table.  
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10. Delete the outer table. Select the outer table and, from the menu, select Table > Delete > Table. 

 

11. Enter a new row at the end of the table to display the department average annual rate. Place 
the cursor inside the row of the table and, from the menu, select Table > Insert > Rows Below. 
Enter Average Rate for the first column in the new row. 

 

12. Change the column headings as shown. 
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13. Add a department average rate field to the last row in the Annual Salary Rate column. Click 
anywhere in the empty Annual Salary Rate column of the Total row to position your cursor. 
Select Insert > Field.  

 

14. In the Field window, select Annual Rt and average for Calculation. Select the On Grouping 
check box. Click Insert and then click Close. 
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15. Your table should look like the image below: 

 

16. Change the format of the column data for Annual Salary Rate. Double click ANNUAL_RT. The 
Text Form Field Options window appears. Change Type to Number. Select the Number format 
$#,##0.00 and edit it as shown. Enter $999 in the Default number field. Click OK. 
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17. Similarly change the format for average ANNUAL_RT. 

 

18. Save the template and preview in PDF format. Select Preview > PDF. The preview report 
displays dummy data. 

 

You can add other Word features to the template. 
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Notes 
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CHA PT ER 6 – DEFINE A NEW REPORT DEFINITION 

Understanding Report Definitions 
Report definitions associate a data source with template files. A data source registers the schema and 
sample data design files. The extracted application fields from the data source files are placed into the 
template files to create the final report. 

A report can include multiple templates. A template is used to associate different layout formats as 
required by different countries and regions or as required by different channels (web posting, printer, 
fax, and so on). 

The defined output options from the report definition are reflected on the output type and format 
prompts on the Process Scheduler request page when the application process that runs the report is 
assigned the process type of XML Publisher. Security settings for a report definition determine who can 
view the report when it has been run. 

Report properties can be set to control formatting of the report. 

With the advanced bursting feature, report generation results in separate output files when bursted 
reports are run through Process Scheduler. 

Report definition access is based on user permission list security and roles. For example, bursting is 
read-only for XML Publisher power users, because only developers can set up bursting, and the page 
only appears when settings exist. 

XML Publisher power users can start to define a report to download the sample data files to create 
their templates. 

Create Report Definitions 

You now define a report with the RTF template that you created. To define the report, perform the 
following steps: 

1. Select XML Publisher > Report Definition. 
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2. On the Report Definition page, click Add a New Value. Enter the report name PERSONAL_PAY. 

 

3. For Data Source ID, click the Look up Datasource icon. 

 

4. Enter P in the begins with field and click the Lookup button. 
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5. From the list, select PERSONAL_DATA_PAY as the data source. Click the Add button. 

 

6. On the Definition tab, enter a description for the report. Select Active as the Report Status. 

 

7. Click the lookup icon for Report Category ID. 
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8. Select the ALLUSER category. 

 

9. On the Template tab, upload the RTF template. Set the template Status to Active.  
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10. Click the Upload button. Browse for the Personal_Data_Pay.rtf template and click Upload. 

 

11. On the Output tab, select PDF as the default output. Click Save. You can now view the report in 
the Report Viewer. 
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CHAPTER 7 – RUN AND VIEW THE BI PUBLISHER REPORT 
 

1. From the left navigation bar in PeopleSoft Applications, select Reporting Tools > XML Publisher 
> Query Report Viewer.  

 

2. On the Query Report Viewer page, click the Search button. 

 
 

3. From the list of reports, select PERSONAL_PAY and then click View Report. 

 

4. While the report is being processed, the word Processing appears at the top. After processing is 
complete, a three-page PDF report is displayed with charts and a table. 
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Congratulations! You just created a report in PeopleSoft Applications using XML Publisher! 
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Appendix A - Incorporating Sub-Templates  

Understanding Sub-Templates  
You may have text, images, or logic in your templates that you want to reuse across 
many report templates. Examples include company headquarter address information 
or standard legal language. Rather than replicate this text, code in every template, or 
both, you can store sub-template files that include the reusable content. These sub-
template files are referenced with standard XSL commands in the primary template 
file. Sub-template functionality is available for use only with primary RTF and XSL 
templates. 

Sub-templates are secondary RTF or XSL templates that are imported by primary RTF 
or XSL report templates. The primary template accesses the sub-template through 
the XSL import style sheet feature. You can import any XSL style sheets or other RTF 
or XSL templates using standard XSL import and call functions. PeopleTools simplified 
sub-template syntax is also supported. 

Primary templates calling nonexistent or inactive sub-templates causes an error 
message to be issued indicating the reason for the problem. This error information is 
incorporated into Process Scheduler error handling as well as into online viewing or 
previewing of the report.  

The sub-template files are independently stored and are not registered in association 
with a data source or primary template. This being the case, if any form fields exist 
inside the sub-template, the report in which the sub-template is placed must have a 
related data source that supplies those fields, or the data must be passed in as 
runtime parameters. 

The Content Library is a component provided for the registration of reusable sub-
template files. The metadata is similar to that of primary template files and includes 
the sub-template ID, sub-template description, language, object owner ID, report 
category, effective date, and status. As with Report Definition security, sub-template 
editor registration security is applied through report categories. Because Report 
Category secures the data in the component, you can assign select users read-only 
access for a report category. These users can browse, view, and download sub-
template files but not add them. This facilitates the offline design of primary 
templates for users who can access the library of existing sub-templates but who 
can’t alter them.  

Sub-template names are not exposed to the end user at either report design time or 
runtime. The complete template (primary and sub-templates) is systematically 
assembled by the XML Publisher engine during report generation. The same occurs 
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during online previewing as long as the sub-template file exists.  

When designing a template, you can incorporate one or more sub-templates into 
your primary template.  

You must use specific syntax to: 

• Create sub-templates. 
• Import sub-templates. 
• Call sub-templates. 

Creating Sub-Templates  
Within a single sub-template file, multiple sub-template components can be available. Start 
and end template indicators must exist to distinguish these various components.  

<?template:component_name?> 
<?end template?> 

For example, syntax of a sub-template file containing two components could be: 

<?template:peoplesoft?> 
Pleasanton Campus 
500 Oracle Lane 
Pleasanton, CA  94488  
<?end template?> 
 
<?template:logo2x.5?> 
 Oracle_Logo 
<?end template?> 

where <?template:peoplesoft?> is the start template indicator of the component peoplesoft 
and <?template:logo2x.5?> is the start template indicator of the component logo2x.5. Each 
<?end  

template?> tag indicates the end of its respective component. 

Importing Sub-Templates  

To import a sub-template file that is stored in the Content Library, place the following syntax 
at the top of the primary template file:  

<?import:psxmlp://sub-template_NAME?> 

where sub-template_NAME is the registered sub-template ID in the Content Library, for 
example: <?import:psxmlp://STDHEADER?>. This syntax must be in Normal text.  

Calling Sub-Templates  
Place the following syntax in the primary template file in the location where the desired text or 
XSL instructions from the sub-template file should appear: 

<?call-template:peoplesoft?> 

In the preceding sample code peoplesoft is the name of the component that you want to use 
in the sub-template file. 

Testing a Sub-Template in Microsoft Word 
You should test your template and sub-template using Template Builder before uploading to 
PeopleTools to make your sub-template is accessible to your template on the file system.  
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Use the following syntax when importing:  

<?import:file:C:///Template_Directory/subtemplate_file.rtf?> 

Notice the triple slashes and the use of the actual file name instead of template ID. 

When your design is complete, you can change the import statement back to make the sub-
template available to the main template in PeopleTools environment: 
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Appendix B:  Including Images 
BI Publisher supports a number of methods for including images in your reports: 

• Inserting images. 

• Importing images. 

Inserting Images  
To directly insert a .jpg, .gif, or .png image file into a template: 

1. Select Insert, Picture, From File while the template is open in Microsoft Word. 

2. Select the desired .jpg, .gif, or .png file to insert into the template. 

3. Save the template. 

Importing Images  
To import an image from a sub-template file: 

1. Embed the .jpg, .gif, or .png into the sub-template file. 

For example,  

<?template:logo2x.5?> 
 Oracle_Logo 
<?end template?> 

where Oracle_Logo is the actual .jpg, .gif, or .png. 

2. Import the sub-template file that includes the image by including the following syntax 
at the top of the primary template file: 

<?import:psxmlp://sub-template_NAME?> 

In this code sample, sub-template_NAME is the registered sub-template ID in the 
Content Library. 

3. Add the calling details in the primary template at the appropriate location using the 
following syntax: 

<?call-template:logo2x.5?> 

In this code sample, logo2x.5 is the name of the component that contains the image 
in the sub-template file. 
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Appendix C:  Changing Default Template Font  
The output report from RTF template uses template-level default fonts for empty report 
spaces and empty table cells. If the default font size does not match the font height used in a 
template, a final report could look different from user expectations. In this case, the user can 
change the template default font either in design time or runtime: 

• Design time 

• Set the xdo.cfg for the font. For example, set the default font for a specific report to be 
Helvetica, size 8: <property  

name="rtf-output-default-font">Helvetica:8</property>  

• Runtime 

Use PeopleCode to set the font. For example, set the default font for a specific report 
to be Times New Roman with height 10: 

&asPropName = CreateArrayRept("", 0); 
&asPropValue = CreateArrayRept("", 0);             
&asPropName.Push(""rtf-output-default-font"); 
&asPropValue.Push(""Times New Roman:10"); 
&oRptDefn.SetRuntimeProperties(&asPropName, &asPropValue); 
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Appendix D:  Using Drilling URL in RTF Template 
Drilling URLs are supported in XML Publisher reports with a data source of PS Query or 
Connected Query. 

To use a drilling URL in a XML Publisher report: 

1. Create the query with the drilling URL defined as a field. 

2. Create an RTF template. 

3. In the RTF template map one or more fields to the fields that contain drilling URL. 

• Highlight the field where you want to place the drilling URL. 

• Select Insert (from the Word menu), Hyperlink or use Ctrl+K. 

• In the Insert Hyperlink dialog box, enter the URL link in Address field.  

Each URL link should be defined as {URL_FIELD}, where URL_FIELD is the 
unique field name for the expression that contains a specific drilling URL. 

  

• Use the Target Frame push button to select how this URL link will be opened, 
either in the same window or in the new window 

4. If the XML Publisher report is run in Process Scheduler using an application engine 
program, you will need to add additional code to identify the process instance for the 
application engine program before processing the report. The process instance can 
be retrieved from the state record PSXPQRYRPT_AET. This call is needed to set a 
drilling URL during Query or Connected Query execution.  

5. &ProcessInstance=PSXPQRYRPT_AET.PROCESS_INSTANCE  
6. &oRptDefn.ProcessInstance = &ProcessInstance; 

&oRptDefn.ProcessReport("", "", %Date, ""); 

7. When you click the drilling URL in the report depending on the drilling URL type, one 
of the following occurs: 

• For Query URL, the Query results are displayed. 
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• For Component URL, the appropriate PeopleSoft page is opened. 

• For External URL, the external page is opened. 
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Appendix E:  Template Builder Template Options 

Inserting a Field  

This dialog allows you to select data elements defined in the data source (that is, the XML 
file) and insert them into the template. From the Insert menu select Field… to open the Field 
dialog. 

The dialog shows the structure of your loaded data source in a tree view, as shown in the 
following figure: 

 

Select a field that represents a single data field (a leaf node of the tree) and select Insert 
(you can also insert the field by dragging and dropping it into your document, or by double-
clicking the field). A text form field with hidden BI Publisher commands (in the help text of 
the form field) is inserted at the cursor position in the template. You may either select and 
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insert additional data fields or close the dialog by clicking the Close button. 

Example 

When you select a field name in the tree view, an example value for this field is shown.  

Find 

For an XML document with a large and complicated structure, use the find functionality to 
find a specific field. Enter a partial string of the field name you are searching into the Find 
field and select Find Next. The next occurrence of a data element that includes your search 
expression will be selected. Click the Find Next button again to see the next occurrence. 

Force LTR (Left-to-Right) Direction 

This checkbox is only needed if you are using the template in a language that prints the 
characters from right to left, such as Arabic or Hebrew. In these languages you still may want 
to force left-to-right printing for fields such as phone numbers, addresses, postal/zip codes, 
or bank account numbers. 

Calculation 

This feature enables you to perform aggregation functions on data fields, such as sum, 
average, count, minimum, and maximum. 

For example, if you select sum for a data field, the field will show the sum of all 
occurring values for this data field, depending on the grouping. 

It is important to understand the grouping context (marked by G and E form fields) 
to know exactly which fields are accumulated. If you insert a data field with an 
accumulation function into a repeating section (marked by G and E processing 
instruction form fields), you must select On Grouping to accumulate the data for the 
occurrences within the group. If you do not want the accumulation to be restricted 
to the group, you must place the accumulation field outside the group. 

For example: 
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Also note that the data field must be a valid XSL number for the accumulation 
functions to work. Formatted numbers cannot be processed by BI Publisher (for 
example a number using a thousands separator: 10,000,000.00 cannot be 
processed). 

Insert Table Wizard 

The Insert Table Wizard enables you to create standard reports. On the Insert menu select 
Table Wizard.  

Step 1:  Select Report Format 

You start by selecting the basic report format. You can choose from Table, Form or Free 
Form. The following example shows how the each selection will appear in the report. 

  

Table Last Name First Name Phone 
Doe John (123) 456-7890 

 

Form Last Name John 
First Doe 
Phone (123) 456-7890 

 

Freeform John 

Doe 

(123) 456-7890 
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Step 2:  Select Table Data 

An XML document can maintain many different datasets. For example, a purchase order 
XML document may contain header level information, lines, shipments and contacts. In this 
step, you select the data group that contains the data you would like to see in your table. 

For example, in the Balance Letter sample RTF template (found in your Template Builder 
installed files under Oracle\BI Publisher\BI Publisher Desktop\samples\RTF Templates), the 
sample XML file contains three data groups as follows: 

• ARXCOBLX/G_CUSTOMER  
• ARXCOBLX/G_CUSTOMER/G_CURRENCY  
• ARXCOBLX/G_CUSTOMER/G_CURRENCY/G_INVOICES  

The Table Wizard presents a list of the available data groups in your loaded XML data file. 
Choose the group that contains the data fields you wish to include in your table. To build a 
table to list the invoices contained in the data, you would select 
ARXCOBLX/G_CUSTOMER/G_CURRENCY/G_INVOICES as your data set. 

Step 3:  Select Data Fields 

The Table Wizard presents the data fields from your selected data set. Use the shuttle 
buttons to select the data fields to show in your table. Use the up and down arrows if you 
wish to reorder the fields after selecting them.  

Step 4: Group Table 

In this step, you can group the report by selected data fields. This is optional. This step 
enables you to regroup the data by a particular field. For example, if you are building a table 
of invoices, you may want to group all invoices of a particular type or date to be grouped 
together in the report.  

There are two options for grouping: Group Left or Group Above. Group Left will create a 
nested table. The Group By field will display to the left in the outer table. Group Above will 
create a new table for each new value of your group by field, displaying the value of the 
group by field as a table title. Examples follow: 

Group Left shows the result as a nested table: 

  

Grouping 
Header 

Grouping Header 

Grouping Field Header 1 Header 2 Header 3 Header 4 Header 5 
Data 1 Data 2 Data 3  Date 4 Data 5 
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Group Above shows the result as a table with a header: 

Grouping Field 1 

Header 1 Header 2 Header 3 Header 4 Header 5 
Data 1 Data 2 Data 3  Date 4 Data 5 

 

Step 5: Sort Report 

In this step, you can sort the data in the table by up to 4 different fields. Select a field and 
then define the sorting order (ascending or descending), and select the correct data type for 
the field. For example, if text is select “12” will come before “2” (alphanumerical order). If 
number is selected, “2” will come before “12”.  
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Step 6: Headers/Labels 

By default the column headers will display as the data field name. If you wish to change the 
column header labels, you can enter the labels here. Select Finish to create the layout and 
customize it in Microsoft Word. 

Insert Table/Form Dialog 

The Insert Table/Form dialog is the most flexible tool of the template builder. It allows you 
to perform the following tasks: 

• Create a simple or nested table with a variable number of rows.  
• Associate a group of data elements, such as a complete invoice or a purchase order 

line, with a form in the document that will be repeated for each occurrence of the 
data element.  

• Select and define a layout for all the data fields in the template.  
• Group or re-group the data.  

On the Insert menu select Table/Form to open the dialog. 

The Insert Table/Form dialog shows you two tree view panes. The left pane shows the data 
source structure, while the right pane shows the elements that will be copied to the 
template when you click the Insert button. 

Note: This dialog is based on the Drag & Drop paradigm. 

Selecting Data Fields 

First select the data fields that you want to insert in the template and then define how to 
format them. Drag an XML element from the left Data Source pane to the right Template 
pane to select it. If the XML element has children, you will see a pop-up menu with the 
following options: 

 Drop Single Node 
  Drop All Nodes 
 Cancel 

Select Drop Single Node if you want to move only the selected node or Drop All Nodes if 
you want to move the node and all its children 

If you drag an additional data field from the left Data Source pane to the right Template 
pane, it is either inserted at the same level (Same Level) or below the node (Child) where 
you release the node. The Insert Position box defines where the node is inserted. 

Note: If you use the left mouse button for drag and drop, the node and all children are 
copied. However, if you use the right mouse button for dragging, a dialog pops up when you 
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release the mouse button. The dialog gives you the option to copy either only the selected 
node or the selected node and all children. 

Find 

For an XML document with a large and complicated structure, use the find functionality to 
find a specific field. Enter a partial string of the field name you are searching for into the Find 
field and click the Find Next button. The next occurrence of a name that includes your 
search string will be selected. Click the Find Next button again to see the next occurrence. 

Example 

When you select a field name in the data source view, an example value from the sample 
XML file for this data field is shown below the view behind Example. 

Defining the Layout 

When you select an element in the right Template pane, you will see its properties as well as 
a preview of how the node will be rendered. There are two kinds of nodes: 

 Data Fields 
 Data Groups 

Data Field nodes (leaf nodes) do not have any child nodes. They represent simple attributes 
such as the total amount for an invoice or the subtotal for a purchase order line. 

Data Group nodes (parent nodes) are nodes that do have child nodes. Typically, they do not 
represent data attributes, but groups of data – such as an invoice, a purchase order, a 
purchase order line or a shipment. 

Data Field Properties 

If a Data Field node is selected, its properties are shown in the Properties pane. You have 
the following options to describe how the Template Builder should show the field: 

Calculation 

You can select one of the aggregation functions for the data fields. These functions 
(besides count) only have an effect when there is more than one of the data fields in the 
context where you use the function. 

Force LTR (Left-to-Right) Direction 

This check box is only needed if you are using the template in a language that displays 
characters from right to left, such as Arabic or Hebrew. In these languages you still may 
want to force left-to-right printing for fields such as phone numbers, addresses, 
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postal/zip codes, or bank account numbers. 

Data Group Properties 

The order in which the data elements are shown reflects the order of the columns in the 
table. If you want to reorder the columns, change the Insert Position box from Child to 
Same Level. Then drag the elements into the correct order. 

If a Data Group node is selected, its properties are shown in the Properties pane. You have 
the following options to describe how the Template Builder should render the group: 

Style 

To display the data as a horizontal table with a header, select Table. To display the 
fields below each other with labels in a table, use Form. If you want to insert the 
fields into a free-form text section that should to repeated for this element select 
Free Form. 

Grouping:  

Grouping is an advanced operation that allows you to group the data by a specific 
element in the data. For example, you may want to group all your invoices by 
customer. You can select a child element of the selected element as a grouping 
criterion. 

Show Grouping Value:  

This property will only be shown if you have selected a node created by the 
Grouping functionality. By default, the field you have selected to group the data by 
will be displayed in the report. If you do not want the grouping data field displayed, 
select No.  

Sort By:  

You can select an element by which the data groups are sorted. 

 

Sort Order 

If you have selected an element for Sort By you can select if the data should be 
sorted either ascending or descending. 

  

Sort Data Type 
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If you have selected an element for Sort By the data is by default sorted as text. That 
means that 12 will be shown after 111. If the data is numeric, select Number as the 
sort data type 

Break 

This property allows you to insert a page break or a section break between every 
data group. If you select New Page per Element, then a page break will be inserted 
between each element after the first occurrence.  

Tip: If you wish to insert a page break before the first occurrence of an 
element, use Microsoft Word's page break command.  

If you select New Section per Element, a section break will be created for each data 
group. A section break has the following effects: it inserts page break, it resets the 
page numbers and new data can be displayed in the header and footer. You will 
typically use this option if you want to print multiple documents (for example 
invoices or purchase orders) to a single PDF file. 

  

Inserting Tables and Forms 

Once you have dragged all data fields over and defined the layout, select the Insert button to 
place the tables and forms at the cursor position in your document.  

Grouping 

You can group any Data Group node, by any of its child Data Field Nodes. For example if you 
have sales data for multiple quarters, you may want to show the sales data organized by 
quarter. In this case you would group the sales data rows by the quarter element. 

Assume the following structure: 

Sales Transaction 

Quarter 

 Customer 

Amount 

  

To group the child nodes of a node (Sales Transaction), you select one of the child nodes 
(Quarter) as the grouping property of the parent node (Sales Transaction). The Template 
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Builder will make this node (e.g. quarter) the parent of the other child nodes (Customer and 
Amount). 

The new structure will look like: 

Sales Transaction 

Quarter 

Customer 

Amount 

  

The grouping criterion (Quarter) now behaves like any other Data Group Node with children. 
That means that you can define the layout of its children using the Create As Table, Style, 
Label, Grouping, and Show Grouping Value properties. 

Advanced Information 

The Insert Table/Form Dialog creates two kinds of form fields: 

 Form fields representing data elements 
 Form fields with processing instructions for repeating table rows or document 

sections 

Form fields representing data elements are replaced with the data when the template is 
processed. Form fields indicating repeating sections are shown as for-each and end for-each 
in the document. (Note: If you have selected the Abbreviated form field display option, the 
for-each and end for-each form fields will display as F and E.)The section of the document 
encapsulated by these two elements is repeated, if the associated data element is repeated 
in the data.  

Insert Chart Dialog 

The insert chart dialog allows you to insert a data driven chart into a template. To open the 
insert chart dialog select the Insert menu, then Chart…. 

Select a data element in the Data pane that you would like to associate with the graph. For 
example, you may have multiple invoices in the single XML document. If you select the root 
node containing all invoices, the graph will be calculated over all invoices. However, if you 
select the invoice node, the graph will be calculated using the data for a single invoice. 
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Chart Type 

BI Publisher’s charting feature is based on Oracle Business Intelligence Beans and it will offer 
all chart types provided by that module. Currently you can choose one of the following 
options: 

• Bar Graph – Vertical  
• Bar - Vertical - Percent  
• Bar - Vertical - Stacked  
• Bar Graph – Horizontal  
• Bar - Horizontal - Percent  
• Bar - Horizontal - Stacked  
• Pie Chart  
• Line Graph  
• Line - Percent  
• Line - Stacked  
• Area Graph  
• Area - Percent  
• Area - Stacked  
• Ring Graph  
• 3-D Bar Graph  
• Radar Graph  
• Pareto Graph  
• Combination Graph  
• Scatter Graph  
• Bubble Graph  
• Stock Graph  
• Stock Graph - Candle  

Values  

Drag and drop the data value you want to measure to the Values field (for example, SALES).  
You can select multiple Value elements (measures). 

Note: The Values field will change depending on the Chart Type you select: 

• Combination Graph- enables three fields for the Value selections.  
• Scatter Graph - a scatter graph compares pairs of values. Drag and drop the X and Y 

data elements to compare.  
• Bubble Graph - a bubble graph compares sets of three values. Similar to the scatter 

chart, the third value is displayed as the size of the bubble.  
• Stock Graph - drag and drop the elements that represent the Open, High, Low, Close, 

and Volume values for the stock graph.  

Aggregation 

You can choose to aggregate the Values data as a sum, a count, or an average. 
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Labels 

Drag and drop the data element for which you want to see the Value charted (for example, 
Year). Select Group Data to group the occurrences of the label element before rendering it 
in the chart. For example, if you are charting Sales by Year, selecting Group Data will 
accumulate the values for Year, so that only one occurrence of each year will appear in the 
chart. If you do not select Group Data, then the value for every occurrence of Year in the 
data will be plotted separately. 

Color 

If you wish to add a series element to the chart, drag and drop the element to display as a 
series. Each value will display as a new color in the graph. 

Chart is inside group 

Select this box if your chart is inside a grouping and you want the chart to display data only 
for the occurrences of the data elements within the group. 

  
Style 

Select a color scheme and style for your chart. 

Properties 

The properties region enables you to change value and label display names, select color, 
font, and other display options for your chart. The properties list will change depending on 
your chart selection. 

Preview 

Click Preview to display the chart with the sample data you have loaded. 

Grouping 

You can group a data group by any of its attributes. For example, if you have invoices in 
multiple currencies, you can group the invoices by currencies and create a graph for each 
currency.  

Select a data field node, which is used to group the data in the Grouping box. Next select an 
aggregation function for the Measure. The data will be aggregated using the aggregation 
function. 

Inserting the Chart 

After you have defined the layout, select Insert. BI Publisher creates a chart in the template 
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using the sample data. 

Editing an Inserted Chart 

To edit a chart that you have already inserted into your template, right-click the chart and 
select BI Publisher Chart from the menu. This will invoke the chart dialog to enable you to 
edit your chart. 

Inserting a Crosstab 
The Template Builder enables you to quickly build a crosstab within your report.  

To use the Cross tab builder: 

1. From the BI Publisher menu bar select Insert, then Cross Tab. The Cross Tab dialog 
presents your data in the left pane empty Layout panes on the right for you to drag 
and drop data elements. The following figure shows the Cross Tab builder dialog:  

 

2. Drag and drop the elements from the Data pane to the Layout pane to build your 
crosstab structure. The following example Layout shows Sales by Industry 
accumulated by Year and by Month:  

 71 



Creating PeopleSoft Reports using XML Publisher 
 

 

3. Use the drop down lists to select aggregation. You can choose Sum, Count, or 
Average. Then choose a number format mask (from the adjacent drop down list) if 
desired  

4. You can choose whether to display subtotals and totals for the rows and columns by 
selecting the Subtotal and Total boxes.  

5. Select Preview to see how the cross tab will appear before you insert it into your 
template. Click OK to insert the cross tab into your template. The sample cross tab 
will appear as follows in your template:  

 
At runtime, the cross tab will generate in your report as follows: 
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Inserting a Repeating Group 
To create a repeating group: 

1. Select the section of the template that contains the elements you want repeated.  
2. From the Oracle BI Publisher menu, select Insert, then Repeating Group.  
3. Enter the appropriate fields in the Field Properties dialog:  

 

For Each - Select the element that for each occurrence of which, you want the loop 
to repeat. When you select the For Each data field you are telling BI Publisher that 
for each occurrence of the selected field in the data you want the elements and 
processing instructions contained within the loop to be repeated. For example, 
assume your data contains invoice data for customers and you want to create a 
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table with each customer's invoices. In this case, for each customer number you 
want the table to repeat. You would therefore select the customer number in the 
For Each field to create a new loop (or group) for each customer. 
Note the following about creating repeating groups: 

o For loops and groupings not inside another group (that is, outer groups or 
loops) you must select the repeating XML element to be used. For example if 
the data set is flat, the only repeatable element is 
/DATA/ROWSET/ROW. In cases with multiple data sources or hierarchical 
XML you can choose the data set.  

o If you are creating nested groups (inserting a loop or group inside of another 
loop in the template), the For Each field is not updateable because it is 
already defined by the preexisting outer loop. The For Each field will display 
"Group Item" to inform you that an outer group is already defined.  

Absolute Path - Select this check box to use the Absolute Path to the element in the 
XML structure. This is important if your data contains the same element name 
grouped under different parent elements. 

Group By - Select a field from the list by which you want to group the data. If you just 
want to create a simple loop, do not select a group by element. Selecting a group by 
element will actually regroup the data into a new hierarchy based on the group by 
element.  

Break - use this option to create either a Page break or Section break if you wish to 
insert a break after each occurrence of this group.  

Note that a Section break can only be created on outer groups that surround the 
whole document. If the selected field is not an outer group, the Section break option 
will not be available.  
Note also that when you insert a section break, the page numbering is reset, headers 
and footers are reset, and any running calculations will be reset for each occurrence 
of the the group. 

4. To sort the grouped data, select the Sorting tab. You can select up to four sort-by 
fields. For each sort by field, select the following:  

Sort order - select Ascending or Descending. 

Data Type - Select Number or Date/Text. It is important that you select the correct 
data type to achieve the expected sort order. 

Note that if you are sorting by four criteria and your XML data element names are 
long, you may exceed the character length limitation (393 characters) of the Microsoft 
Word form field. 

5. The Advanced tab enables you to edit the code directly and to enter Text to Display 
for the field. The Code region displays the code and processing instructions that the 
Template Builder has inserted for the field. You can edit this if you wish to change 
the processing instructions for this field. The Text to Display field shows how this 
field will display in your template. You can choose to enter descriptive text to enable 
you to understand each field better when reading the template, or you can enter 
abbreviated text entries that will be less intrusive to the look and feel of the 
template.  
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Note: The default display text can be set as Descriptive or Abbreviated using the 
Options tab. 

The following figure shows the Advanced tab of the Repeating Group Field Properties 
dialog:  

 

6. When you have completed the dialog options, click OK. This will insert the form 
fields in your template. By default, the beginning for-each form field will display the 
text "F" and will be inserted at the beginning of the selected template section. At the 
end of the selection, an "E" form field will be inserted to denote the end of the 
repeating group.  

Creating Grouping Fields Around an Existing Block 
To create a group around an existing block of text in a template: 

1. Select the block of text. For example, a table row.  

Note that if any already inserted BI Publisher tags are included in the block, you 
must be sure to include the beginning and ending tags. For example, if your block 
contains any opening for-each, if, or for-each-group tags, you must include the 
end for-each, end-if, and end for-each-group tags in your selection. 

2. From the Oracle BI Publisher menu bar select Insert, then Repeating Group.  
3. In the Field Properties dialog, enter the fields to define the group as described in 

Inserting a Repeating Group.  
4. Click OK to insert the grouping fields around the block. For example, if the block is a 

table row, the begin field will be inserted at the beginning of the first cell and the 
end field will put at the end of the last field.  

Inserting and Editing Conditional Regions 
A conditional region is an area that is surrounded by a conditional statement. If the statement 
tests true, the area is displayed in the report; if the condition tests false, the area is 
suppressed from the report.  
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For example, your data contains salary and position information for all employees. Your report 
contains a table that displays the employee, position, and salary. You want your report to 
display salary information for managers only. Using the insert conditional region functionality, 
you can select the region that contains the employee table and insert the condition that the 
position element must equal manager. 

To insert a conditional region: 

1. Select the region that you want to apply the condition to. For example, if you want 
to display a table only for a certain condition, select the region that contains the 
table. Note that the region must be inside a loop.  

2. From the Oracle BI Publisher toolbar, select Insert, then Conditional Region. The 
following figure shows the Conditional Region dialog.  

 

3. Enter the following fields:  

Data Field — Select the field to test for the condition. 

Select the data type of the field: Number or Date/Text. 

(Condition 1) Data field — Select the comparison operator. The options are: 

o Equal to  
o Not equal to  
o Greater than  
o Less than  
o Greater than or equal to  
o Less than or equal to  

Select the value to meet the condition. Note that you may enter an integer, enter text, 
or select another data element to define a comparison based on the incoming values. 

4. Click OK. The form fields containing the conditional logic are inserted around the 
region. The beginning form field will display the text "C" and the form field closing 
the region will display the text "EC".  

5. To edit the conditional region, double-click the inserted form field to launch the 
dialog for editing; or, right-click the form field and select BI Publisher, then 
Properties.  
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Inserting Conditional Formatting 
Using the Advanced Form Field features, you can insert simple conditional formats to apply to 
table rows or cells. The dialog provides several common options that you can select and the 
Template Builder inserts the code automatically. The Conditional Format dialog supports two 
conditions per field. 

Use this feature to easily construct formats such as displaying values below a certain 
threshold in one format, and above the threshold in another. 

To insert a conditional format: 

1. Place the cursor in the table cell of the data element for which you want to define 
the condition.  

2. From the Oracle BI Publisher toolbar, select Insert, then Conditional Format. The 
following figure shows the Conditional Format dialog.  

 

3. Enter the following in the Conditional Format dialog  

Data Field — Select the element to test for the condition and the data type of the 
element (Number or Date/Text). 

Apply to Entire Table Row — If you want the format applied to the entire table row, 
not just the cell of the selected element, select this box. 

(Condition 1) Data field — Select the comparison operator. The options are: 

o Equal to  
o Not equal to  
o Greater than  
o Less than  
o Greater than or equal to  
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o Less than or equal to  

Select the value to meet the condition. Note that you may enter an integer, enter text, 
or select another data element to define a comparison based on the incoming values. 

4. Click Format to define the format you want to apply when the condition is met. 
Options are background color, font color, and font style (regular, bold, italic, bold 
italic). Select the box and format of each option you want to apply. After you select 
the format, the Preview region will display the format chosen.  The following figure 
shows the Format dialog from the Conditional Format dialog:  

 

5. Define a second condition if desired.  
6. Select OK. The conditional format field will be inserted as a form field with the 

display text "C".  
7. To edit the conditional format, double-click the inserted form field to launch the 

dialog for editing; or, right-click the form field and select BI Publisher, then 
Properties.  
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