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Using BI Publisher with PeopleSoft Query for Report Developers 
 
Introduction 
 
The following describes the basic steps used in creating and publishing reports using BI Publisher (BIP) with PeopleSoft 
Query.   This document explains procedures for users with the Report Developer security Role.  Those users with the 
Power User Role, - except for the inability to register Data Sources - can generally perform the tasks below as well.   
 
There is a chart at the end of the document (Appendix A) that displays the access available to these two groups. 
 
This documentation is divided into these main sections: 
 

• BI Publisher Overview 
• Installing Oracle BI Publisher Desktop 
• How to Use BI Publisher through to Query Viewer or Query Report Scheduler 

1) Create a query or modify an existing query 
2) Register Data Source 
3) Create a Template in Word 
4) Set Up Report Definition – associate with Templace 
5) Run, View and Save the BI Publisher Report 

• Appendix A:  Chart displaying access for Report Developer and Power User 
• Appendix B:  Links to other documentation 

 
NOTE regarding Communication Generation (Comm Gen) 

In addition to the reporting capabilities discussed here, BI Publisher enables you to manage and merge 
communication templates and data source files for the Communication Generation process to generate 
letters or emails.  Comm Gen will not be reviewed here, but you can read about it in detail on the Comm 
Gen page in the SFIS Blog. 

 
Before you can work with BI Publisher, you need to: 

• Install Oracle BI Publisher Desktop through Design Helper 
 

Important Note regarding Active Status:   
There are three places where Status needs to be changed to Active –  

(1) Data Source * 
(2) Report Definition [Definition page] and  
(3) Report Definition [Template page].   

If these Statuses are not changed to Active, various processes will not run.  
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BI Publisher Overview  
 
BI Publisher is a standalone Java-based reporting technology (formerly XML Publisher or XMLP) that streamlines report 
and form generation.  A primary feature of Oracle's BI Publisher product is the separation of the data extraction process 
from the report layout.  BI Publisher provides the ability to design and create report layout templates with the more 
common desktop applications of Microsoft Word and Adobe Acrobat, and renders XML data based on those templates.  
With a single template, it can generate reports in many formats.   
 
The following diagram illustrates the concept of BI Publisher. 
 

 
 
Select features of Oracle's BI Publisher product have been integrated into and enhanced for use with PeopleTools.  BI 
Publisher for PeopleSoft Enterprise makes Oracle BI Publisher technology natively accessible from PeopleSoft Query.  BI 
Publisher for PeopleSoft Enterprise provides an environment for managing templates, data sources, reports, and 
content components. It also offers an electronic bursting capability to produce reports according to user-defined 
criteria, and the reports can be secured using an application’s security join table.   
 
There are two aspects of this integration: 
 

1. Design time, during which a report definition is registered, and a data source is associated with a template.   
2. Runtime, when the definitional information is called by the page viewer or processing program to produce the 

formatted output. 
 
The BI Publisher Menu Navigation is:  Main Menu > Reporting Tools > BI Publisher.  These are the Functional Area 
Navigation (FAN) menu contents of BI Publisher available to Report Developers and Power Users    
 

Note:  The Data Source, Translations, Report Category  
and Global Properties options are only available  

to those with the Report Developer Role. 
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Below are descriptions of the pages found under these menus. 
 
Report Developer 

 
 
Data Source*:  User queries are data sources that the application uses to retrieve data for a BI Publisher report.   
When creating a report definition, you can select a PeopleSoft Query data source that has not yet been registered and 
that data source is registered automatically once the report definition is saved.  However, it is simpler for a Report 
Developer to register the Data Source beforehand.  Note regarding non-query data sources:  Before you create any 
report – if the data source is not a query [XML files, and various other types of data sources] - you must create and 
register a data source. 
 
Report Definition:  This is where you describe various aspects of your report and associate the data source with a 
template.  The pages under Report Definition are: 

• Definition – Specify description and category of report.   
• Template – Upload the template file once it’s been created. 
• Output – Specify the output report format and set a default format.  
• Security – Specify the Role or User who should have access to the report.  
• Bursting * – Specify the criteria if you need to burst the report. Leave it blank if bursting is not needed.  

 
Content Library:  A component provided for the registration of reusable sub-template files.  You may have text, images, 
or logic in your templates that you want to reuse across many report templates. Examples include address information 
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or standard language.  Rather than replicate this text and/or code in every template, you have the ability to store sub-
template files that include the reusable content. 
 
Translations *:  Language translation. 
 
Query Report Viewer:  The Query Report Viewer allows selection and online viewing of those reports that have a data 
source type of PeopleSoft Query.  Existing Query security applies so that each user has access to run only the reports to 
which he or she has qualified Query access to the data source.   You can save reports from the Viewer. 

Query Report Scheduler:  Schedule reports. 
 
BIP Report Search:  Search for reports. 
 
Design Helper:  One of the items on both menus, under Setup, is Design Helper (it is the last option on the FAN menu).  
Design Helper is the point from which you will install Oracle BI Publisher Desktop.   
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Installing Oracle BI Publisher Desktop (Design Helper) 
 
IMPORTANT:  Before you can utilize BI Publisher, you must install an add-in called Oracle BI Publisher Desktop through 
the use of the Design Helper.  Navigate to Main Menu > Reporting Tools > BI Publisher > Setup > Design Helper.  
Following are the menus available under Setup. 
 

 

 
 
When you click on the link shown below under Design Helper, you will be instructed to download the Template Builder.  
Refer to the Oracle document entitled Creating PeopleSoft Reports Using XML Publisher for information about using 
the Design Helper.  
 

 

Having trouble downloading the Design Helper? 
Depending on the version of Office you have on your 
computer, the download process may not go as 
smoothly as indicated in the instructions.  If that occurs, 
please send a Service Now ticket to Desktop Support 
explaining the situation in detail. 
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How to Use BI Publisher: 

 
1. Create a query or modify an existing query 

a. To maximize the value of this tool, use it for reports, forms and other documents with output that would not 
be possible with another product, for example, Word Mail Merge. 

b. Design how the output should appear and determine which fields are required before creating the query. 
c. The query should contain all the fields that need to appear in the report. 
d. The query should also contain fields that will be used in the Word template for grouping purposes, even if 

they will be hidden in the report. 
e. Keep the query as simple as possible; however, since the query can be used for multiple templates to create 

multiple reports, thought should be given to what additional fields may be appropriate for future use. 
f. For ease of use when working on the template, arrange the fields in the same order as they will appear on 

the document. 
g. Do as much formatting as possible within the query itself.  For example, it is important that dates and times 

be formatted through expressions.   
h. Heading Text - Change the Heading Text as needed; for example, make abbreviations full words, etc. since 

headers may appear on the report.  See example below. 
i. Unique Field Name (on the Edit Field Properties page in Query Manager) – If there are expressions used in 

the query or there are other fields that have a Unique Field Name that are somewhat ambiguous, change 
Unique Field Name since you will be referencing it when creating the template.  A simple, clear name will be 
easier to work with. 

j. Prompts may be used in the query. 
k. As with any query, best practices for good query design should be employed. 
l. Test the query and note the results for comparison with the report results.  
m. Query:  For this demonstration of creating a query to register a Data Source, a query has been created 

based on international schools approved by OIS (WOIS_EXT_ORGS_NRS_INTL_ONLY).     
 

i. Tables:  The query is based on two tables:  EXT_ORG_PRI_VW and COUNTRY_TBL. 
 

ii. Fields:  These are the fields and their attributes.   
Record.Fieldname Format Ord XLAT Heading Text 

A.EXT_ORG_ID - External Org ID Char11     Org ID 

A.EXT_ORG_TYPE - Organization Type Char4     Org Type 

A.PROPRIETORSHIP - Proprietorship Char4   N Ownership 

A.COUNTRY - Country Char3 1   Country 

B.DESCR - Description Char30     Country Description 

A.DESCR50 - Description Char50 2   Organization Description 
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iii. Criteria:  The criteria are as follows: 
Logical Expression1 Condition Type Expression 2 

  A.EFFDT - Effective Date Eff Date <= Current Date 

AND A.EFF_STATUS - Status as of Effective Date equal to A 

AND A.EXT_ORG_TYPE - Organization Type equal to NRS 

AND A.PROPRIETORSHIP - Proprietorship equal to INTL 

AND (A.COUNTRY - Country is not null   
OR A.COUNTRY - Country greater than 0) 

AND B.COUNTRY - Country equal to A.COUNTRY - Country 
 

iv. Query Output:  The ultimate report will display the institutions categorized and grouped by 
Country.  The beginning of the query results looks like this: 

 
 

n. The first step in the BI Publisher process is to register this query as a Data Source for use in the Word 
Template.  You register the query under the BI Publisher > Data Source page. 

i. This function is only available to the Report Developer.  
2. Register Data Source (Reporting Tools > BI Publisher > Data Source) 

a. Since there is no existing Data Source, click on Add a New Value 
b. It should default to a Data Source Type of PS Query.  If so, you do not have to make a change.  Otherwise, 

select PS Query from the dropdown. 
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c. Next to Data Source ID you can type the name of the query, or the first few letters to narrow the selection. 

Once you’ve done so, the page will resemble the following.  Note that the “Private Data Source” box is not 
checked.  This indicates that the query being used is a Public Query.  In this example, the query name is 
WOIS_EXT_ORGS_NRS_INTL_ONLY. 

i. To the right is a checkbox labeled Private Data Source.  This would only be checked if it were a 
Private Query. 
 

 
 

d. Once you have typed the query name, click on the Add button.  The Data Source page will open as follows: 
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e. Description:  (Optional)   Enter descriptive text that provides more detail about the data source.  The 
description automatically defaults to the Data Source ID when you click Save. 

f. Object Owner ID:  (Optional)   Indicate which product, feature, or application owns this data source. 
g. Registered Date/Time:  This is a read-only field maintained by the system that indicates the date that the 

initial data source registration was made.  
h. Last Update Date/Time:  This is a read-only field maintained by the system that indicates the date that the 

last update to the data source was made.  
i. Active:  If not already checked, select to indicate that this is an active data source.   

i. Only active data sources can be chosen when creating a new report definition.  
ii. Only reports with active data sources can be processed.  

j. Registered By:  This is a read-only field maintained by the system that indicates the user ID of the operator 
who initially registered the data source.  

k. Updated By:  This is a read-only field maintained by the system that indicates the user ID of the operator 
who last updated the data source. 

l. Click Generate under the Generate File column for Sample Data File.   
m. Click Generate under the Generate File column for Schema File.   
n. After the Data Source is generated, an XML file for WOIS_EXT_ORGS_NRS_INTL_ONLY is created.  Click the 

Save button. 

 
 

o. To take a look at the xml file, click the WOIS_EXT_ORGS_NRS_INTL_ONLY.XML link.   
i. The browser appears and displays the XML data in the file.  Below is the beginning of the XML 

file: 
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ii. Save the XML file in an appropriate directory.  You will be accessing the XML file in Step 4 when 
you create the Word template.   

1. can create the Report Definition at any time. 
 

3. Create a Template in Word 
a. Once the Sample Data (XML file) has been saved, open Word 
b.  Select Add-Ins from the menu 

 

 
 

c. To gain access to the XML Data, click on Data – Load XML Data… 
 

 
 

d. Windows Explorer opens.  Navigate to the directory where you saved the XML file (in this example, 
WOIS_EXT_ORGS_NRS_INTL_VER2.XML) 

e. Click to open the file.  When the following message appears, click OK. 
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f. For this demonstration, we are creating a table that will be categorized by Country.  As you can see from 

this menu, there are a number of ways to begin working in Word.   
i. To being inserting the fields and formatting the template, click on Insert. 

 

 
 

ii. The Insert menu appears as follows.  There are a number of methods for inserting the fields into 
the Word template.  In addition, there are many ways to format and otherwise refine the final 
output.  The easiest way to display all rows of data is to use the Table Wizard. 

iii. For this example, click on Table/Form.   

 

 
 
 

g. The following form opens displaying information about the query, including the field names (under 
Row). 
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h. Click on Row and drag it from the first column to the middle column (headed Template) and select Drop 
All Nodes from the popup menu that will appear.   

 
 

i. Your other options are Drop Single Node or Cancel, i.e. you can drop nodes one at a time or 
cancel the process.  Dropping all at once, and then deleting, is generally the most effective 
method.   
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i. Delete the following fields from the Template column by selecting the field and right-clicking to delete.   
i. @rownumber 

ii. Ext Org Type (Org Type) 
iii. Proprietorship (Ownership) 
iv. Country (Country Code) 

j. There will be three fields remaining in the center panel.  The Template panel will now appear as follows: 
 

 
 

k. All of the fields should be directly beneath Row as shown above.  Note:  If you were to do a sub-
grouping (which is not covered here) the display would be different. 

l. If you click on any of the fields or on Row, the properties in the third panel (Properties) will change.  You 
can see below that the Ext Org Id field is highlighted in the center panel, and that the properties appear 
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on the right.  Also note that in the “Preview” section below that the highlighted field is displayed in a 
different color. 

 

 
 

m. When you click on Row, the right panel shows these options: 
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n. Next, provide the grouping details.   
i. With the Properties window Name as “row” 

ii. Click on the down arrow next to Grouping, so that it lists the fields as follows.  
 

 
 

iii. Select DESCR (which is the Country Name field) from the dropdown list for the Grouping 
property. 

 

 
 

o. Click OK.  You are returned to Word where the following grid is now available.   
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p. Use Word features and select the G DESCR field and cut and paste above the table. 

 
 

q. Select the inner table and control character E (as shown). 
 

 
 

r. Cut and paste the selected area a few lines below the outer table. 

 
 

s. Delete the outer table (the empty table with the Descr labels) as follows:  Rest the pointer over the table 
until the table move handle  appears, and then click the table move handle.  Press BACKSPACE.   The 
outer table should disappear. 
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t. The grid now appears as follows: 
 

 
 
u. Make some formatting changes in Word. 

i. At the top of the page, enter a title:  Listing of OIS Approved Institutions by Country 
ii. Delete one row between G DESCR and the grid 

iii. Change the width of the columns 
iv. Change the titles of the columns as follows: 

1. Ext Org ID – change to Organization ID 
2. Descr50 – change to Institution Name 

 

 
v. Note regarding page breaks:  If you want to insert a page break while working in a template, the break 

needs to be placed before both of the “E” codes.  For example, in this instance: 
i. Move the location of the “E” which is currently after “DESCR50 to a position before the last “E” 

ii. Place the cursor before the two codes, and press the CTRL-Break key combination. 
iii. To verify that a page break has been entered, you can click on Paragraph in the Word menu.   

w. Save the template as First SampleTemplate.rtf.  If you perform the next step without saving the 
template, you will receive instructions to do so. 

x. Preview its appearance as an RTF file by clicking on Add-Ins > Preview, then RTF.  It will display fake 
data.  This copy is not the actual template. 

y. Note:  If at any time you click on Preview and do not receive output that appears to be related to the 
original query, click Data – Load XML Data to load in the correct XML. 
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4. Set Up Report Definition (Reporting Tools > BI Publisher > Report Definition) 

a. Open Report Definition 

 
 

b. Click on the Add a New Value link.  When the next page opens, enter a Report Name.  Note that there is a 
12-character limit. 

c. The Data Source Type * is grayed out for Power Users.   
 

Report Developer * Power User 
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d. In the Data Source ID dropdown box you can search for the query by typing in all or the first few letters of 
the query name.   If you do not type in the entire name, a list of queries will be displayed. 

 

 
e. Click the Add button.  The following group of pages will appear (Note:  The Power User will not have the 

Bursting page).   
 

 
 
 

f. Start with the Definition page by entering a name for the report in Report Description.   
g. Under Report Status, change In Progress to Active. 
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h. Under Report Category ID, select an appropriate Report Category. 
i. Set the Template Type as RTF if it is not already. 
j. The Definition page should now appear as follows: 
k. Click on the Template tab.  Notice that the Report Name is displayed at the top.  There is now a Template 

ID that consists of the Report Name and ends in “_1.”  You’ll see that you can add other templates based 
on this Report Name by using the add buttons to the right.  Successive Template ID numbers will end in 
“_2,” etc. 

 
 

l. In order to save the Report Definition, you must associate a template with it.   
i. On the Template page, upload the RTF template by clicking on the Upload button (Note:  In 

Internet Explorer, you may need to hold down the CTRL key at the same time).    
ii. Depending on your browser, a popup menu will appear prompting you to browse for the file. 

iii. Click on the yellow Upload button to browse for and upload the template file that you recently 
saved. 

 
 

m. Once you have uploaded the template, you will see its name listed next to the label Template File at the 
bottom of the page, in the Template Files section. 

i. You can create more than one Template by clicking on the plus sign in the first part of the page.  
Different Templates can have the same date. 
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ii. Template Files, however, cannot have the same date.   (If you are editing and testing a 
template, you can do so one of two ways:  Add a new Template or add a new Template File by 
making Effective Date, under Template Files, a date prior to today.  Template Files cannot have 
the same date, so this will enable you to create a number of Template Files at one time if 
necessary.) 

n. Change the Status from In Progress to Active. 
 

 
 

o. Click on the Output tab. 

 
 

p. Select RTF as the Default. 
q. Save the Report Definition by clicking on the Save button in the lower left 

 
 

5.  Run, View and Save BI Publisher Report (Reporting Tools > BI Publisher > Query Report Viewer)   
Below are two methods for running, viewing and saving the BI Publisher Report:  (a) Query Report Viewer 
and (b) Query Report Scheduler 
 

a. On the Query Report Viewer page, click the Search button 
i. If there were more than one Template associated with the Report Name, you would click on the 

Show Template Prompts link to view them all.  In this case there is just one template, and the 
correct format, RTF is displayed.  Click on View Report.    
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ii. The RTF file opens, and the first page appears as follows: 
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iii. This shows the beginning of a 13-page report that has the institutions sorted and grouped by 
Country, and then alphabetically by name. 

iv. There are no page breaks in this report as shown here.  At any time you can go back into the 
template and make formatting or other changes.  If you do, you will need to upload the 
template again in Report Definition to have the latest version associated. 

v. You may save a copy of the report by doing a Save As an RTF file.  You can use it as an RTF file or 
save the RTF file as a Word document. 

b. Query Report Scheduler  (Reporting Tools > BI Publisher > Query Report Scheduler) 
 

 
 

i. Create a new Run Control.  The following page opens. 
 
 

 
 
 

ii. Populate the fields as follows: 
a) Data Source Type:  The default should be Query.  If it is not, change it to Query. 
b) Report Name:  You can search for or enter the entire name. 
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c) Template ID:  If there is just one Template, this field will fill in automatically based 
on the Report Name.  If there is more than one Template, you will choose from the 
dropdown. 

d) Template As Of Date:  To be filled in if the date is a factor. 
e) Note that, if entered a Channel earlier, it is Channel is prepopulated with that entry. 

iii. Click on Save to save this Run Control 
iv. Click on Run 

 

 
v. Click on OK and then on Process Monitor.  Basically, run this as you would any Process 

Scheduler process. 
vi. Once the Run Status is at Success and Distribution Status is at Posted, click on the link Go 

back to Query Report Scheduler. 
vii. Click on the Report Manager link.  You will see the following: 

 
viii. Click on the Report link (OIS_APPROVE2 – OIS_APPROVE2.rtf).  When the next page opens, click 

on the Name link (OIS_APPROVE2.rtf) 
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ix. You will be prompted to save the RTF file. 
x. The beginning of the first page appears as shown. 
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xi. As mentioned above, you can edit, format or make any changes to the RTF template.  After you 
do so, you will need to upload the template again into Report Definition. 
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Appendix A – Chart displaying access for Report Developer and Power User 
 
 

  XMLP Report 
Developer 
(PTPT2600) 

XMLP Power User 
(PTPT2500) 

Report Category Yes No 
Design Helper Yes Yes 
Data Source Yes No 
Report Definition Yes Yes 

Note. Display Only 
access for bursting. 

Content Library Yes Yes 
Template 
Translations 

Yes No 

Query Report 
Viewer 

Yes Yes 

Query Report 
Scheduler 

Yes Yes 

Report 
Repository 

Yes Yes 
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Appendix B – Links to Other Documentation 
 

 See a demonstration of how to register a Data Source starting on page 10 of Creating 
PeopleSoft Reports Using XML Publisher entitled Create and Register a Data Source.  

 The following documents show methods for working with Templates 
 Oracle BI Publisher Template Builder for Word 10.1.3.3.0  - a quick tutorial 

showing Insert Table/Form and Creating Charts 
 Links to PeopleSoft Recordings on Formatting BI Publisher Template – 

demonstrations of conditional formatting, formatting dates and numbers, page 
level calculations, page breaks, pages numbers , and shapes 

 XMLP Templates by Example – Insert Table/Form, grouping, totals and tallies, 
summaries, conditional formatting, formatting numbers 

 Creating PeopleSoft Reports Using XML Publisher – Create a Pie Chart and Bar 
Chart, Create a Table (Table/Form), formatting, calculations 

 These are HEUG presentations or instructions from HEUG members with useful 
template information: 
 BI Publisher for the Registrar’s Office (UNT Health Center) - includes 

 Basic Techniques 
 Table Wizard and Sorting 
 Tables and Formatting 
 Advanced Techniques 
 Date Formatting 
 IF Statements – Conditional Format 

 BI Publisher Course (Clackamas County) – see Chapter 5, Page 28 about templates.  It 
looks like it comes from the Oracle documentation.  These appear to be good overall 
instructions for using BIP. 
 Pie Chart, Bar Chart 
 Create a Table – Formatting 

 Also, while working in PeopleSoft, check the Help link for documentation in 
PeopleBooks. 
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http://sfis.blogs.wesleyan.edu/files/2013/02/ORACLE-Creating-PeopleSoft-Reports-Using-XML-Publisher.pdf
http://sfis.blogs.wesleyan.edu/files/2013/02/ORACLE-Creating-PeopleSoft-Reports-Using-XML-Publisher.pdf
http://sfis.blogs.wesleyan.edu/files/2014/10/ORACLE-Template-Builder-for-Word-Tutorial.pdf
http://sfis.blogs.wesleyan.edu/files/2015/09/Oracle-ps-links-BI-publisher-recordings.pdf
http://sfis.blogs.wesleyan.edu/files/2013/02/XMLPTemplatesByExample.pdf
http://sfis.blogs.wesleyan.edu/files/2013/02/XMLPTemplatesByExample.pdf
http://www.oracle.com/webfolder/technetwork/tutorials/obe/fmw/bi/xmlp_ps/index.html
http://www.oracle.com/webfolder/technetwork/tutorials/obe/fmw/bi/xmlp_ps/index.html
http://sfis.blogs.wesleyan.edu/files/2014/09/SCHRUG2014-2002-BI-Publisher-UPDATED.pdf
http://sfis.blogs.wesleyan.edu/files/2015/10/BI_Publisher-course-HEUG-Clackamas-County.pdf
http://sfis.blogs.wesleyan.edu/files/2015/10/BI_Publisher-course-HEUG-Clackamas-County.pdf

