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BI PUBLISHER TEMPLATE BUILDER QUICK TUTORIAL - 
ANNOTATED 

• The following is an annotated version of an Oracle “quick tutorial” document to introduce 
the user to working with BI Publisher Templates.   

• The annotations were added to clarify how the information is presented and to remove 
material that does not apply to our installation. 

• The annotations are in dark red italics, or are bordered in dark red. 
• Some original formatting has been changed to make the instructions more clear. 
• Text in need of further emphasis has been highlighted in yellow. 
• Some text or screenshots different from our installation have been deleted or replaced. 

 

This tutorial uses files that were installed on your computer at the time that the Design Helper 
was installed.  They can all be found under C:\Program Files\Oracle\BI Publisher\BI 
Publisher Desktop 

 

Welcome to Oracle BI Publisher 
 Template Builder for Word 10.1.3.3.0! 
Introduction 
The Template Builder is an extension to Microsoft Word that simplifies the development of RTF templates. 
While the Template Builder is not required to create RTF templates, it provides many functions that will 
increase your productivity. 
 
The Template Builder is tightly integrated with Microsoft Word and allows you to perform the following 
functions: 
 

 Insert data fields into your RTF templates 
 Insert data driven tables and crosstabs 
 Insert data driven charts 
 Preview and Validate RTF templates with sample XML data 
 Browse and update the content of form fields 
 Extract boilerplate text into an XLIFF translation file and test translations 

 
This help document assumes a basic working knowledge of Oracle BI Publisher. Please refer to the 
Oracle BI Publisher User’s Guide for additional information. This Template Builder version is based on BI 
Publisher 10.1.3.3.0. 
 
If the template builder is installed correctly, you will see an additional item in Word called Add-Ins that 
appears as follows: 
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Quick Tutorial 
This tutorial describes how you would typically create a simple layout template. You will create a letter 
that shows the outstanding balance for a customer. This letter contains a table of all unpaid or partially 
paid invoices. 

Load Word File 
 

• Often a template starts from an example document in the form of a regular Microsoft Word 
document.  

• For this tutorial go to the samples\RTF templates\Balance Letter folder under your BI Publisher 
installation directory (e.g. C:\Program Files\Oracle\BI Publisher Desktop) and load the file 
Balance Letter Start.rtf.  

o Navigation:  C:\Program Files\Oracle\BI Publisher\BI Publisher Desktop\samples\RTF 
Templates\Balance Letter\Balance Letter Start.rtf 

• This file represents a Word document that has not been marked up for use with Oracle BI 
Publisher. 

• The text in the file looks like this: 
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Load Sample XML Data 
 

• Click on the Add-Ins menu.  The BI Publisher menu opens 
 

 
 

• To load the sample XML data file, click on the Data menu and select Load XML Data 
 

 
 

• From the Oracle BI Publisher > Data menu select Load XML Data to load a sample XML 
document that contains the data fields you may want to insert into your RTF layout template.  

• For this tutorial go to the samples\RTF templates\Balance Letter folder under your BI Publisher 
installation directory and load the file Balance.xml. 

o Navigation:   C:\Program Files\Oracle\BI Publisher\BI Publisher Desktop\samples\RTF 
Templates\Balance Letter\Balance.xml 

• When this message appears, click OK 
 

 

Insert Form Fields 
• You may want to select single data fields, such as the customer name and address at the header 

of the letter.  
• Position the cursor in the Word document where you want to insert the Address.  
• Open the Add-Ins > Insert menu. 
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• From the Oracle BI Publisher > Insert menu select Field… to open the dialog window shown 
below. 

 
 

 
 

• Select the field Customer Name and click Insert to insert a form field for the customer name into 
the document.  

o You may also insert the remaining address fields (such as Address Line1 to 4, City, 
State and Zip).  

 
• Starting with this version, you can also just drag the Customer Name field from the dialog and 

drop it into the Word document. NEW! 
 

• You can also select the fields, As of Date, Trx Currency Code and the C Inv Open Balance 
and insert them into the appropriate spaces in the document. 

 
• Note: As a beginner, you should use Insert Fields only for data fields that are unique (not 

repeating) in your document. Refer to the “Insert Table” section for additional information on how 
to insert repetitive fields 
 

• Once you have inserted the fields listed above, that portion of the document will resemble the 
following, depending upon how many address lines you include: 
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Preview Template 
• After adding fields to the document, you may want to test your template.  

o Oracle BI Publisher Template Builder allows you to preview your template with your 
sample XML data.  

o You can preview the output in Adobe Acrobat Reader (PDF), Microsoft Word file (RTF), 
Microsoft EXCEL (EXCEL) or a browser (HTML). 

 
• From the Oracle BI Publisher > Preview menu select HTML to preview your template in a 

browser. From the Oracle BI Publisher > Preview menu select PDF to preview your document 
in Acrobat Reader. You must have Adobe Acrobat Reader version 5.0 or higher installed to 
preview documents in PDF format. You can download Acrobat Reader for free at 
http://www.adobe.com/products/acrobat/readstep2.html. 

 
• Click on Add-Ins and then the Preview menu 

 

 
 

• The preview should show Vision Corporation instead of the field Customer Name. 
 

• The fields should look like this: 
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• Once you have viewed the Preview, you can delete it.  The RTF file will not be affected. 

Insert Table 
• You can build a table or a repeating section by inserting the elements and then adding additional 

form fields with processing instructions (for-each). 
o  Instead, the Template Builder offers an additional function that generates a table for you. 

• The Template Builder can generate for-each instructions either as descriptive or abbreviated.  
• Abbreviated instructions are less invasive to the appearance of the document, while descriptive 

processing instructions make the template easier to understand.  
• Open Add-ins > Tools > Options  

 
 

 
 
 

• For this tutorial, select Options… from the Oracle BI Publisher menu, switch to the Build tab 
and select Descriptive as shown below. 
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• The document should include a table of all invoices that are not or only partially paid.  
• On the Oracle BI Publisher > Insert menu select Table/Form… to open the Table/Form Dialog. 

The following dialog will be displayed: 
 

 
 

• Scroll in the left Data Source view pane until you see the G Invoices element.  
• Push the left mouse button and drag the G Invoices element over to the center Template tree 

view.  
• When you drop an element with children (other elements below the element), the following pop-

up dialog appears: 
 

 
 

Note: A Node is a term used in tree views for an element in the tree view. For example, Customer 
Name, G Currency and G Invoices are all nodes. Transaction Date is also called a child node of 
G Invoices, and G Invoices is referred to as a parent node of Transaction Date.  
 

• To add multiple nodes, click Drop All Nodes with the left mouse button. When you select the "G 
Invoices" node, the dialog box should now look like this: 
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• We only want to show the fields Trx Number, Transaction Date, Trans Amount, and Trans 
Amount Remaining.  

o Select the field Trans Type in the center view and press the Delete button on your 
keyboard.  Note:  You can also left click on the field and drag and drop it back into the left 
column. 

o Repeat the procedure for the other fields that you do not want to be included in the table 
(as shown in the screenshot below).  

 
• You should now click again on the G Invoices element in the center view.  

 
• The Properties region on the right shows how the data fields will be formatted. You should see 

the following information: 
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For each group you can set the following properties that describe how a group (such as G Invoices) 
should be rendered by the template builder: 
 

Style: Select Table to create a table around the data fields. 
 
Grouping: Grouping is an advanced operation that allows you to re-group the data – for example 
by transaction date instead of currency. You can select the element that the data should be 
grouped by for this property. Please refer to the Oracle BI Publisher User’s Guide for additional 
information on grouping. 
 
Show Grouping Value: This property will only be shown if you have selected a node created by 
the Grouping functionality. You can choose for a group if the Data Field node used as a grouping 
criterion is shown in the table or form. 
 
Sort By: You can select an element by which the data groups are sorted. 
 
Sort Order: If you have selected an element for Sort By you can select, if the data should be 
sorted either ascending or descending. 
 
Sort Data Type: If you have selected an element for Sort By the data is by default sorted as 
Text. That means that 12 will be shown after 111. If you need to sort numbers you should select 
Number as the sort data type 
 
Break: This property allows you to insert a page break or a section break between every data 
group. If nothing is select, then the data groups will be shown continuously with no break. If you 
select New Page per Element, then a page break will be inserted between each element. If you 
select New Section per Element, a section break will be created for each data group. A section 
break allows changing the header/footer and resets the page number. You will typically use this 
option, if you want to print multiple documents (for example invoices or purchase orders) to a 
single PDF file. 
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o The order in which the data elements are shown reflects the order of the columns in the table. If 
you want to reorder the columns you need to change the Insert Position box from Child to 
Same Level. Then drag the elements into the correct order. 

 
Click the OK button to create the table. The inserted table should look like this: 
 
Trx Number Transaction Date Trans Amount Trans Amount Remaining 
for-each 
G_INVOICES 
TRX_NUMBER 

TRANSACTION_DATE TRANS_AMOUNT TRANS_AMOUNT_REMAINING  
end G_INVOICES 

 
The Template Builder creates two kinds of form fields: 
 

 Form fields representing data elements 
 Form fields with processing instructions for repeating table rows or document section 

 
o Form fields representing data elements are replaced with the data when the template is 

processed.  
o The for-each G_INVOICES and end G_INVOICES form fields indicate a repeating section.  

o The section of the document encapsulated by these two form fields is repeated, if the 
associated data element G_INVOICE is found repetitively in the data.  

o Please refer to the Oracle BI Publisher User’s Guide for additional information on form 
fields. 
 

o You can now format these elements in Microsoft Word and add additional text.  
 

o You can also move fields around as long as you keep them in the surrounding for-each 
G_INVOICES and end G_INVOICES processing instruction.  

o If you remove one of these processing instructions your template may not work anymore 
with BI Publisher. 

 
o You now can preview the template again to review your current template (see above).  

o You probably would like to change the alignment of the table columns or change the data 
type and format for the amounts.  

o For example, select the TRANS_AMOUNT field, right-click and select BI Publisher -> 
Properties to see the Properties dialog.  
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o Under Formatting:   

o You may select the Number in the Type field,  
o #,##0.00 for Number format and  

o Under General:   
o enter 1000 as the Text to Display to achieve a more desirable format for currencies 

in US Dollar.  (When you enter 1000 and click OK, it will appear as shown above:  
1,000.00.) 

o Important:  Be sure that the Text to display box is not empty in order that you can see the field in the 
Template table.  

o We recommend not to use currency signs such as $ in the format string, since it may lead to 
difficulties in supporting multiple languages with a single template. 

 
• If you changed the Text to display field, Trans Amount now looks like this in the Template table: 

 

 
 

• If you run the Preview now, you’ll see that the Trans Amount field has been formatted as above. 
• You can make the same changes for the Trans Amount Remaining field and to the 

C_INV_OPEN_BALANCE field in the body of the letter. 
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Formatting options defined in this dialog box are understood by Oracle BI Publisher and used to format 
your fields. Try to modify the template to get an idea which Word functions are supported by BI Publisher 
10.1.3.2. 
 
 
 

 

Creating Charts 
• The data used for creating the open balance letter is not well suited to create a chart.  
• Close the previous Word document and open a new Word document.  
• Then load the RetailSales.xml file in the samples\RTF templates\Sales Report folder by 

selecting Load XML Data from the Data menu.  
o Navigation:  C:\Program Files\Oracle\BI Publisher\BI Publisher Desktop\samples\RTF 

Templates\Sales Report\Retail Sales.xml  
 

• This data contains retail sales data for different industries. We will create a chart that shows the 
sales per industry.  

• BI Publisher does not support native Microsoft Word Charts. You need to create charts using the 
Template Builder.  

 
On the Oracle BI Publisher > Insert menu select Chart… to open the Chart Dialog.  
 
 

 
 
 
 
The following dialog will be displayed: 
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• On the left tree view pane you may drag Industry to the Labels field, because we want to see 
the data accumulated by industry.  

o Then we drag the Sales to the Values field.  
o We select a Pie Chart as the Type  

 

 
 

o and click the Preview button to see how the chart will look like with our sample data.  
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• Then we click OK to insert the chart into the RTF template. 
• The Template Builder will insert the placeholder image shown below for the chart. To change the 

size of the chart, you can just resize the placeholder image. 
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From the Preview menu select HTML to preview your template in a browser. From the Preview menu 
select PDF to preview the output in Acrobat Reader.  The preview will show the correct chart for the 
preview data: 
 

 
 
Please refer to the Oracle BI Publisher User’s Guide for additional information regarding charts. 

Next Steps 
• This concludes the quick tutorial.   
• Try to create your own template now.   
• Refer to the help file for additional information.  
• You should also consult section 2 “RTF Templates” of the Oracle BI Publisher User’s Guide  
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